Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 24, 2025 - 19:00 CET
Scheduled
To improve and optimize the performance of the SMTP server for sending periodic messages, we will perform a complete cleaning of the logs. The confirmation emails for the registration of new accounts will not be affected by this maintenance.
Posted Jan 20, 2025 - 14:45 CET
This scheduled maintenance affected: MYETV (Email services).