Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 04, 2025 - 19:59 CEST
Scheduled
Today we had a problem with the SSL certificate for one of our subdomains dealing with distributing content; the problem has been solved and now all the contents of that subdomain are back available.
Posted Aug 04, 2025 - 19:58 CEST
This scheduled maintenance affected: MYETV (https://www.myetv.tv - MYETV PLATFORM).